Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
shkolar345
04.02.2023 14:37 •
Информатика
Составить программу по паскалю! определить количество чисел с цифрой 4 в записи числа
Ответ:
valerya7000
04.10.2020 20:26
Var
ar:array[1..2000] of integer;
n,i,count:integer;
begin
readln(n);
for i:=1 to n do begin
read(ar[i]);
while ((ar[i]>0) and ((ar[i] mod 10)<>4)) do ar[i]:=ar[i] div 10;
if ar[i] mod 10 = 4 then inc(count);
end;
writeln(count);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
glazalmahfidbbw
13.01.2023 07:46
Составить программу вычисления стоимости покупки с учётом скидки. скидка 3% предоставляется в том случае, если сумма покупки больше 500 рублей, 5% - если сумма больше 1000 рублей....
missirinasmirn
03.12.2022 05:19
Напишите программы в ! 10. программа вычисляет n факториал ( факториалом натурального числа n называется произведение всех чисел от 1 до n, включая n 11. составьте программу,...
Eugenrar
07.06.2021 02:44
Кто разбирается в Microsoft Access? Нужна Только на русский переведите...
Aki1Nozomi
31.03.2023 08:20
Определите, сколько звёздочек будет напечатано в результате вызова F(7)? procedure F(n: integer); begin if n 1 then begin write(‘ * ’); F(n - 1); F(n div 2) End; end; Нужно...
sachachura
23.09.2021 09:07
В каталоге находятся файлы со следующими именами: file.mdb; file.mp3; ilona.mpg; pile.mpg; miles.mp3; nil.mpeg. Определите, по какой из масок будет выбрана указанная группа...
marat2002671
10.06.2021 04:50
5а,124(16) с обяснением даю...
sobennikovaox
14.08.2022 08:16
Иван десять секунд записывал двухканальную запись с частотой дискретизации 16 кгц и глубиной кодирования 24 бита. затем он 10 секунд записывал одноканальную запись с теми же...
ValeriyaPetra
07.03.2023 21:10
Выберите и запишите грамматически правильные варианты из данных скобках. 1.John is a very gifted film director. What is the name of his (last/latest) comedy? And when will his...
Galiavey370
04.10.2021 19:25
Яка сила тяжіння діє на автомобілі мосою 3т?...
lidafilinp016fh
17.10.2021 03:29
Доклад 5 класс по биологии круговорот живых организмов. Именно ЖИВЫХ организмов Очень нужен, можно привести пример...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
ar:array[1..2000] of integer;
n,i,count:integer;
begin
readln(n);
for i:=1 to n do begin
read(ar[i]);
while ((ar[i]>0) and ((ar[i] mod 10)<>4)) do ar[i]:=ar[i] div 10;
if ar[i] mod 10 = 4 then inc(count);
end;
writeln(count);
end.