В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vlada3108
vlada3108
01.12.2022 00:51 •  Информатика

Составить программу, определяющую, все целые числа из промежутка от 300 до 600, у которых сумма делителей кратна 10. язык: с++; ps: нужно решить при do_while

Ответ:
sergey1234567890f
sergey1234567890f
04.10.2020 19:22

#include <iostream>

using namespace std;


int main () {

    

    int digit = 300;

    

    do {

        int sum = 0;

        int teiler = 1;

        

        while (teiler <= digit)

        {

            if (digit % teiler == 0)

                sum+=teiler;

            

            teiler++;

            

        }

        

        if(sum % 10 == 0)

        {

            cout << digit << endl;

        }

        

        digit++;

        

    } while (digit <= 600);

    

    return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?