Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
пушокс
22.04.2020 13:11 •
Информатика
Дан массив из 15 элементов, найти среднее арифметическое этих элементов. , нужно
Ответ:
Asherok
04.10.2020 19:21
Const n=15;
var
a: array[1..n] of integer;
sa: real;
i: byte;
begin
writeln ('Введите ',n,' чисел: ');
sa:=0;
for i:=1 to n do begin;
read (a[i]);
sa:=sa+a[i];
end;
sa:=sa/i;
writeln ('Среднее арифметическое = ',sa);
end.
Введите 15 чисел:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
Среднее арифметическое = 8
0,0
(0 оценок)
Популярные вопросы: Информатика
olesyag8080
17.09.2020 16:01
Значение слова(словосочетания) двоичное число двоичная цифра двоичное кодирование...
Изачка
24.07.2022 23:50
Напишите в паскале z1 = 1 - (1/4 * sin(2a) ^ 2 + cos(2a)) z2 = cos(a) ^ 2 + cos(a) ^ 4...
snkashleva133
25.04.2020 02:16
Яне уверена что сделала правильно...
stasymitaki
23.08.2020 07:20
1. перевести числа в двоичную систему счисления: а) 17 б) 99 в) 175 г) 211 2. перевести числа из двоичной системы счисления в десятичную: а) 10001 б) 111011 в) 1010101 г)...
podenas1969
18.09.2022 01:22
Написать программу на паскале: найти номер первого максимального элемента во вводимой с клавиатуры последовательности чисел. условие окончания ввода – ввод числа 0....
31752
17.04.2020 08:15
Замените одну букву в слове москва. чтобы получилось имя существительное....
Veronicia
17.04.2020 08:15
А) вывести на экран квадрат первых двадцати нечетных чисел. б) найти сумму n четных чисел, количество четных чисел задается в процессе работы программы....
viktoria123987650
03.09.2020 10:47
Вкаком году был создан первый компьютер. в каком году был создан отечественный компьютер...
Uchenicza
03.09.2020 10:47
Напишите программу в паскале для 9класса отображающую третий закон ньютона. если не можете сюда кинуть, киньте на мой мейл - [email protected] заранее...
pasha25013
03.09.2020 10:47
Важно для делимости числа на 3 требуется, чтобы сумма цифр числа делилась на 3. написать функцию проверки делимости n чисел, вводимых с клавиатуры, на 3. паскаль.рекурсия...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
a: array[1..n] of integer;
sa: real;
i: byte;
begin
writeln ('Введите ',n,' чисел: ');
sa:=0;
for i:=1 to n do begin;
read (a[i]);
sa:=sa+a[i];
end;
sa:=sa/i;
writeln ('Среднее арифметическое = ',sa);
end.
Введите 15 чисел:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
Среднее арифметическое = 8