В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
donczowakateri
donczowakateri
04.05.2023 04:51 •  Информатика

100 ! ! напишите программу в python 2.7 или 3.3 по данному числу n выведите все целые степени двойки, не превосходящие n, в порядке возрастания. операцией возведения в степень пользоваться нельзя! входные данные: вводится натуральное число выходные данные: выведите ответ на пример входные данные: 50 выходные данные: 1 2 4 8 16 32

Ответ:
geptor2012
geptor2012
04.10.2020 18:31
Var n,st:integer; begin write('n = '); readln(n); st:=1; while st<=n do begin write(st,' '); st:=st*2; end; writeln; end. Пример: n = 50 1 2 4 8 16 32
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?