В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ildar6464
ildar6464
01.02.2023 22:03 •  Информатика

Лёгкая по паскалю! , ! составьте программу которая позволяет удалить второе слово строки s. строку s, состоящую из 2 слов, разделённых пробеламі, введите с клавbатуры.

Ответ:
aleksandrkozlov1
aleksandrkozlov1
04.10.2020 17:57
Var s: string; x,i: byte;
begin
writeln('Введите строку:');
readln(s);
for i:=2 to length(s) do begin
  if s[i]=' '
    then begin
      x:=i+1;
      while (s[x]<>' ') and (x<length(s)) do begin
        delete(s,x,1);
      end;
      delete(s,x,1);
      break;
    end;
end;
writeln(s);
end.

Пример 1:
мама мыла
мама 
Пример 2:
Мама мыла раму
Мама раму

PS: считается, что строка не начинается с пробела и не может быть два пробела подряд
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?