В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
вівиvi
вівиvi
13.07.2022 09:06 •  Информатика

Составьте программу ввода с клавиатуры элементов массива a 1..10 случайными целыми числами в диапазоне от 1 до 20 и выводит на экран элементы, занчения которых больше 5 и мешьше 15.

Ответ:
asyamilos
asyamilos
02.08.2020 15:24
CONST
n=10;
var mas:array[1..10] of integer;
i:integer;
begin
randomize;
//ввод массива и его вывод на экран
for i:=1 to n do begin
mas[i]:=random(19)+1;
write(mas[i]:4);
if (i=5) then writeln;
end;
//поиск чисел
writeln;
write('Искомые числа: ');
for i:=1 to n  do
if (mas[i]>5) and (mas[i]<15) then write (mas[i]:4);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?