В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Demongirl1
Demongirl1
09.11.2020 03:21 •  Информатика

Написать программу ,которая вычисляет количество четных цифр в числе m длинной

Ответ:
datskivvera1
datskivvera1
04.10.2020 17:42
from random import randint
n = int(input())
m = 0
z=0
for i in range (n):
    b = 10**i * randint(0,9)
    m = m + b
    if (b/10**i) % 2 == 0:
        z = z+1
print(m)
print(z)
0,0(0 оценок)
Ответ:
lizniki82
lizniki82
04.10.2020 17:42
Здесь задается только длина числа, а само число выводится рандомно, но если что, то можно сделать ввод с клавиатуры.

Var
   n,x: integer;
   k,m,i: byte;
 begin
   randomize;
  write ('Введите длину числа (M): ');
  readln (m);
  x:=1; // величина ограничителей значений числа при рандомном вводе
  for i:=2 to m do
    x:=x*10;
  n:=random(x,x*10-1);
  writeln ('n=',n);
  for i:=1 to m do begin
    if (n mod 10) mod 2 =0
      then k:=k+1;
    n:=n div 10;
  end;
  writeln;
  writeln ('В этом числе ',k,' четных цифр');
end.

Пример:
Введите длину числа (M): 4
n=5297

В этом числе 1 четных цифр
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?