В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Natashasergeu
Natashasergeu
10.07.2020 07:26 •  Информатика

Написать программу которая задает с клавиатуры рост 10 спортсменов из диапазона от 150 до 200см считает количество спортсменов рост которых больше 190см а также средний рост всех спортсменов

Ответ:
Петонова03
Петонова03
04.10.2020 17:19
Var
  a: array [1..10] of integer;
  i, s, k: integer;
 
begin

for i:=1 to 10 do
  begin
    Writeln('Рост спортсмена №',i,': ');
    Readln(a[i]);
    if a[i] > 190 then
      k:=k+1;
    s:=s+a[i];
  end;

Writeln(k, ' спортсмена(-ов) рост, которых составляет более 190 см.');

Writeln('Средний рост всех спортсменов составляет ', s/10,' см.');
 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?