В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
алиса760
алиса760
09.02.2022 10:05 •  Информатика

1. напишите программу, которая для последовательности натуральных чисел определяет их сумму. программа получает на вход количество чисел в последовательности и сами числа 2. измените программу так, чтобы определялось произведение чисел. 3. измените программу так, чтобы определялось количество чисел, заканчивающихся на 8

Ответ:
EvGeniusYT
EvGeniusYT
04.10.2020 17:09
1 и 3 пункты
var   n, s: integer;  
begin  
WriteLn('Введите последовательность. Конец ввода - 0');  
repeat    
ReadLn(n);    
if (n > 0) and ((n mod 10 = 8)) then      
s := s + n  
until n = 0;  
WriteLn('Сумма чисел, оканчивающихся на 3 или 9 = ', s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?