В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
jpjpjp
jpjpjp
14.11.2021 22:15 •  Информатика

Всем, нужно написать программу не используя операторы цикла (формулой) длина московской кольцевой автомобильной дороги —109 километров. байкер вася стартует с нулевого километра мкад и едет со скоростью v километров в час. на какой отметке он остановится через t часов? входные данные программа получает на вход значения v и t. если v> 0, то вася движется в положительном направлении по мкад, если же значение v< 0, то в отрицательном. выходные данные программа должна вывести целое число от 0 до 108 — номер отметки, на которой остановится вася.

Ответ:
batareya666
batareya666
31.08.2020 15:29
Var v,t,x:integer;
begin
write('v = ');
readln(v);
write('t = ');
readln(t);
x:=(109+(v*t-(v*t div 109)*109) mod 109) mod 109;
writeln(x);
end.

Пример 1:
v = 50
t = 3
41

Пример 2:
v = -50
t = 3
68
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?