В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nikita140982ee
nikita140982ee
06.01.2020 02:28 •  Информатика

Составьте программу,которая выполняет массив а(1..10) случайными целыми числами в диапазоне от 1 до 10,затем меняет местами первый элемент со вторым,третий с четвертым и т.д. выведите на экран исходный и полученный массивы.

Ответ:
Cfhbcbudh
Cfhbcbudh
04.10.2020 16:18
Program swap;
const
  N = 10;
var
  a: array [1..N] of integer;
  i, temp: integer;
begin
  randomize;
  writeln('исходный массив: ');
  for i := 1 to N do
    begin
      a[i] := Random(10);
      write(a[i], ' ');
    end;
  writeln;
  i := 1;
  while i <= 9 do
    begin
      temp := a[i];
      a[i] := a[i+1];
      a[i+1] := temp;
      i := i + 2;
    end;
  writeln('полученный массив: ');
  for i := 1 to N do
      write(a[i], ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?