В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lizun10
lizun10
01.02.2021 18:35 •  Информатика

60 написать программу, в которой бы с клавиатуры пользователь вводил четыре числа (тип данных real). после этого программа выводила бы на экран номер наибольшего из них. нумерация начинается с 1 без использования массивов

Ответ:
bataev2007
bataev2007
29.05.2020 16:09

Язык С++

#include <iostream>

int main() {

double a, b, c, d;

std::cin >> a >> b >> c >> d;

if (a > b && a > c && a > d) {

 std::cout << 1;

}

else if (b > a && b > c && c > d) {

 std::cout << 2;

}

else if (c > a && c > b && c > d) {

 std::cout << 3;

}

else {

 std::cout << 4;

}

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?