В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mileenkaaa
mileenkaaa
31.01.2022 05:55 •  Информатика

Склавиатуры вводят слова.составьте программу,которая выводит цифры этого числа .например: семь нуль три один шесть четыре ,должно вывести 7 0 3 1 6 4

Ответ:
Karumi1
Karumi1
08.09.2020 13:53
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var w1:=Arr('ноль','один','два','три','четыре','пять','шесть',
    'семь','восемь','девять');
  var w2:=Arr('0','1','2','3','4','5','6','7','8','9');
  var a:=ReadlnString('->').ToWords;
  foreach var w in a do begin
    var i:=w1.FindIndex(p->p=w);
    if i>=0 then Write(w2[i],' ')
    end;
end.

Пример
-> семь ноль три один шесть четыре
7 0 3 1 6 4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?