В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
salome5toriy
salome5toriy
27.10.2022 04:42 •  Информатика

Как составить программу, которая подсчитывает сумму отрицательных чисел (s) и произведение положительных

Ответ:
Yarmoshenkobchmd
Yarmoshenkobchmd
02.08.2020 14:53
const   N = 5;  
var   a, S1, S2: Integer;  
i, Q1, Q2: Byte;  
begin  
S1 := 0; Q1 := 0;  
S2 := 0; Q2 := 0;  
writeln('Введите ', N, ' чисел:');  
for i := 1 to N do
begin    
read(a);    
if a < 0 then
begin      
S1 := S1 + a;      
inc(Q1)    
end;    
if a > 0 then
begin      
S2 := S2 + a;      
inc(Q2)    
end;  
end;  
writeln;  
if Q1 > 0 then
begin    
writeln('Сумма отрицательных чисел: ', S1);    
writeln('Количество отрицательных: ', Q1)  
end  
else
writeln('Отрицательных нет');  
if Q2 > 0 then
begin    
writeln('Сумма положительных чисел: ', S2);    
writeln('Количество положительных: ', Q2)  
end  
else
writeln('Положительных нет')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?