Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
sanya811
01.04.2021 01:51 •
Информатика
Вывод на экран чисел кратных 13. от 10 до 99 их суммы и произведения. (паскаль)
Ответ:
nickartyar
04.10.2020 14:53
Первое число, кратное 13, из диапазона [10;99] - это 13. Остальные будут идти с шагом 13, т.е. получим последовательность 13, 26, 39, ...
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a:=Range(13,99,13); a.Println;
Writeln('S=',a.Sum,', П=',a.Aggregate(Biginteger(1),(m,n)->m*n))
end.
Результат
13 26 39 52 65 78 91
S=364, П=316252525680
0,0
(0 оценок)
Популярные вопросы: Информатика
mita421132
13.12.2021 16:48
Какой тип графического изображения (растровый или векторный) вы будете использовать: 1) для разработки эмблемы организации, учитывая, что она должна будет печататься...
grasdas
13.12.2021 16:48
Составить программу на паскале найти сумму квадратов натуральных чисел от 15 до 25...
тэ10л
31.07.2020 08:59
Запишите на языке Pascal следующее выражение...
NEON2006
16.08.2020 17:12
Примеры единичных имён в следующих множествах: мореплаватель, остров, орфограмма, закон, формула, поэма. 2) примеры возможных, активных, посевных действий для объекта:...
ГюнтерСтингерсон
16.08.2020 17:12
Укажите на минимально необходимый набор устройств для работы на компьютере: вариант 1 клавиатура, монитор, мышь вариант 2 клавиатура, системный блок, монитор вариант...
allapogorelayaoxd0fz
22.02.2022 11:31
с информатикой (промежуточные вычисления не округляйте, ответ округлить надо до десятых) >...
Foxoff
13.11.2021 01:08
Племя Мульти пишет письма, пользуясь 22-символьным алфавитом, а племя Пульти – 32-символьным. Вожди племен обменялись письмами. Письмо племени Мульти содержит 120...
ektgdb
30.12.2022 06:45
Совокупность средств и правил взаимодействия человека и компьютера – это… пользовательский интерфейс аппаратно-программный интерфейс аппаратный интерфейс программный...
юстина6
14.09.2022 09:23
Укажіть хімічну формулу речовини, частка якої у повітрі становить близько 20 %....
Kapitonovakarol
06.10.2021 06:52
Написать цитаты из рассказа, характеризующие бесстрашие, терпение, находчивость героя, любовь к природе В.П. Астафьев. «Васюткино озеро»....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a:=Range(13,99,13); a.Println;
Writeln('S=',a.Sum,', П=',a.Aggregate(Biginteger(1),(m,n)->m*n))
end.
Результат
13 26 39 52 65 78 91
S=364, П=316252525680