В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
drgotika2011
drgotika2011
20.08.2022 13:11 •  Информатика

Написать программу. в программу вводится n чисел, величину n задаёт пользователь, а также числа вводятся подряд. 1.найти сумму введённых чисел. 2.количество чисел равных 0. 3.найти максимум и минимум среди введённых чисел. нужно на языке с. .

Ответ:
БУЛИЧКА23
БУЛИЧКА23
04.10.2020 14:49
Крч вот на паскале, на Си не могу, сорь

program ;
var
A: array [-1000..1000] of integer;
n, i, b : integer;
begin
    writeln('Введите количество чисел');
    readln(n);
    b:=0;
    for i := 1 to n do
        readln(A[i]);
    for i := 0 to (n) do
        b := b+ A[i];
    write('Это сумма ');
    writeln(b); // Это сумма.
    b:=0;
    for i := 1 to (n) do
    begin
        if A[i] = 0 then
            b := b+1
    end;
    write('Это количество нулей ');
    writeln(b) ;// это количество нулей
    b:= -1001;
    for i := 1 to (n) do
    begin
        if A[i] > b then
            b := A[i]
    end;
    write('Это максимальное число ');
    writeln(b); // Это максимальное число
        b:= 1001;
    for i := 1 to (n) do
    begin
        if A[i] < b then
            b := A[i]
    end;
    write('Это минимальное число ');
    writeln(b) // Это минимальное число
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?