В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kosonogova
kosonogova
06.10.2022 06:15 •  Информатика

Pascal abc. составить программу , определяющую , является ли шестизначный номер билета счастливым (у которого сумма первых трех цифр равна сумме последних трех цифр) p.s. нужно использовать div и mod..

Ответ:
дима4класс1
дима4класс1
08.09.2020 13:48
Var a: integer;
 begin
  readln(a);
  if(a div 100000 + ((a div 1000) mod 10) + (((a div 1000) div 10) mod 10) ) = (((a mod 1000) div 100) + ((a mod 1000) mod 10) + (((a mod 1000) div 10) mod 10)) then writeln('Да')
  else writeln('Нет');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?