В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Olga194
Olga194
18.02.2020 07:13 •  Информатика

1)составить программу для поиска наибольшего из 4 чисел. 2) cоставить программу поиска наибольшего из трех чисел с учетом того, что числа могут быть равны. только плз чтобы там было типо такого : var a,b,c,d max: integer

Ответ:
жасик0071
жасик0071
04.10.2020 13:39
1)
var
  a, b, c, d, max: integer;
 begin
  readln(a, b, c, d);
  if(a > b) and (a > c) and (a > d) then max := a
  else if(b > a) and (b > c) and (b > d) then max := b
  else if(c > a) and (c > b) and (c > d) then max := c
  else max := d;
  write(max);
end.
2)
var
a, b, c, max:
integer;
 begin
  readln(a, b, c);
  if(a > b) and (a > c) then max := a
  else if(b > a) and (b > c) then max := b
  else max := c;
  write(max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?