В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Messi294
Messi294
08.05.2021 00:17 •  Информатика

Решить по информатике составьте программу "угадай" . программа задумывает случайное число в диапозоне от 0 до 99 после каждой попытки играющего угадать число программа выводит на экран одно из сообщений больше , меньше или угадано . на отгадывание числа дается 10 попыток программа завершается при выполнении одного из условий : дан правильный ответ либо все попытки исчерпаны

Ответ:
ghj42
ghj42
04.10.2020 12:48
Var
flag,i,x,y:integer;
begin
x:=Random(0,99);
flag:=0;
for i:=1 to 10 do begin
write('Введите ваше число ');
readln(y);
if (x = y) then begin
flag:=1;
writeln('Дан правильный ответ!');
break
end
else
if (x < y) then
writeln('Попробуйте взять число поменьше')
else
writeln('Попробуйте взять число побольше'); 
end;
if flag = 0 then writeln('Все попытки исчерпаны');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?