Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Dangerous0
10.06.2020 11:36 •
Информатика
Напишите программу которая вводит натуральные числа a и n и вычисляет a^n без использования операции возведения в степень.
Ответ:
Nasti12
04.10.2020 12:41
Var a, n, i: integer;
r: longint;
begin
r := 1;
readln(a, n);
for i := 1 to n do
r := r * a;
write(r);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Ясте
19.01.2020 19:45
Почему не всегда можно повысить пропускную канала за счет увеличения числа состояний информационного сигнала?...
Ggogog
20.06.2022 10:43
Посчитай, сколько байт информации содержит 32 бит? ...
andreykotov6
01.07.2021 17:01
12. Назовите функциню кнопки NumLock: А. Управляет работой компьютера с другой кнопки В. Перемещает курсор на следующую строку. С. Удаляет символ после курсора D. Позволяет вводить...
anastasia3004
23.08.2022 20:24
11. Назовите функцио кнопки Home: А. Перемещает курсор на следующую строку. В. Удаляет символ перед курсором. С. Перемещает курсор на начало строки. D. Удаляет символ после курсора....
akame505
01.07.2022 02:44
1) Сколько бит памяти займет слово клавиатура? 2) текст занимает 0,25 кбайт памяти компьютера. Сколько символов содержит этот текст? 3) Сообщение передано в семи битном коде....
Mila19911
19.11.2022 13:14
Для хранения растрового изображения размером 156×156 пикселей отвели 4 КБ памяти. Каково максимально возможное число цветов в палитре изображения НАДО...
OnAcHaYa2o2
17.10.2022 01:14
Из данных предложений выберите высказывания: a)кто присутствует? b)пейте томатный сок! c)озеро байкал находится в восточной сибири. d)число 13 не является простым. e)4+5=10 f)все...
Ололошка580
26.12.2020 19:05
Какой минимальный объем памяти в кбайт нужно зарезервровать, чтобы можно было сохранить любое растровое изображение размером 1280х80 пикселей при условии, что в изображении могут...
LollyPopsi
14.03.2022 08:49
Напишите программу в pytho, которая считывает с клавиатуры два числа a и b, считает и выводит на консоль среднее арифметическое всех чисел из отрезка [a,b]...
samudoma2006
09.08.2022 09:55
В соответствии с кодовой таблицей ASCII каждую латинскую букву можно закодировать десятичным числом. Слово «file» кодируется как 102105108101. Какому слову соответствует числовая...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
r: longint;
begin
r := 1;
readln(a, n);
for i := 1 to n do
r := r * a;
write(r);
end.