В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
pudova20001katya
pudova20001katya
09.03.2021 15:51 •  Информатика

Кто разбирается? короче, такая хрень, ! составьте программу, которая формирует массив из шестнадцати случайных целых чисел от -20 до 20 и: а) находит элементы с нулевыми знаниями; б) находит индексы нечетных элементов; в) подсчитывает количество положительных элементов. -ну? кто тут умный?

Ответ:
den6580
den6580
04.10.2020 12:34
На каком языке программирования?

Паскаль АБС

var
i,count:integer;
a:array [1..16] of integer;
begin
for i:=1 to 16 do begin
a[i]:= Random (-20,20);
end;
for i:=1 to 16 do begin
if (a[i] = 0) then
writeln ('Нулевой элемент ',a [i]);
if (a [i] mod 2 = 1) then
writeln ('Индекс нечетного элемента ',i);
if (a [i] >0) then
inc (count);
end;
writeln ('Количество положительных чисел ',count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?