Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
kuvandykov05
26.08.2020 17:40 •
Информатика
Напишите программу, находящую сумму арифметической прогрессии по заданным значениям первого элемента, разности и количества элементов последовательности.
Ответ:
анна2170
04.10.2020 12:26
1. Вспомним формулу для нахождения суммы арифметической прогрессии:
Где а - это первый элемент последовательности
n - количество элементов
d -разность.
Составим программу на языке СИ
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int a,n,d;
double y;
int main(void)
{
printf("a=");
scanf("%d", &a);
printf("n=");
scanf("%d", &n);
printf("d=");
scanf("%d", &d);
y=((2*a+(n-1)*d)/2.0)*n;
printf("%lf", y);
}
0,0
(0 оценок)
Популярные вопросы: Информатика
смерть73
02.07.2020 00:19
Что будет напечатано в результате выполнения фрагмента программы?...
Zayats2007
06.11.2020 19:26
Привести примеры к данным типпам данных integer float str boolean...
Лилия22111048483
25.01.2023 21:21
Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до...
Ʈгiceгatoρѕ
12.06.2021 20:43
в рассказе После бала упоминается разные виды танцев Определите названия танцев по приведённым ниже описанием и запишите их...
dianadidi3
28.05.2021 22:23
Составьте рассказ 5-7 определенно-личных предложений про школьную жизнь...
savinanika2007p06u72
02.07.2021 14:11
Изменится ли период математического маятника длинной 20 см, если его перенести из одной комнаты в другую? Почему?...
rudnfc
23.12.2022 23:06
розкласти на множники многочлен,c(a-b)-(a-b);(p+5)-x(p+5);4(m-1)+(m-1)^2;(c+8)^2-c(c+8);-3t(t-2)+4(t-2)^2...
veroni4kaa
17.06.2021 01:08
Визначте основні риси боротьби міст за самоврядування....
zhenyakudryash
07.06.2022 04:08
Господи Площадь треугольника равна 96 см^2 , а две стороны этого треугольника равны 16 см и 8 см. Высота, проведенная к большей стороне равна 12см. Найдите высоту, проведенную к...
kostyaluch
20.12.2021 18:57
Вопрос К какому лирическому жанру относится стихотворение Ф. И. Тютчева С поляны коршун поднялся... ? Укажите правильный вариант ответа: ода послание эпиграмма элегия песня...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Где а - это первый элемент последовательности
n - количество элементов
d -разность.
Составим программу на языке СИ
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int a,n,d;
double y;
int main(void)
{
printf("a=");
scanf("%d", &a);
printf("n=");
scanf("%d", &n);
printf("d=");
scanf("%d", &d);
y=((2*a+(n-1)*d)/2.0)*n;
printf("%lf", y);
}