В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kuliksvera
kuliksvera
01.05.2020 00:28 •  Информатика

Составьте программу заполняет массив случайными целыми числами в диапазоне от 0 до10 и находит максимальный элемент массива среди элементов с четными индексами

Ответ:
juliana123456
juliana123456
14.08.2020 12:31
Const n=10;
var a:array [1..n] of integer;
i,max: integer;

begin
randomize;
 for i:=1 to n do
 begin
 a[i]:=random (10);  
write(a[i],' ')
end;
writeln;

max:=a[1];

for i:=1 to n do if (i mod 2 =0) and (max<a[i])
 then max:=a[i];
writeln (max) 

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?