В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ulyalyas
ulyalyas
28.01.2023 15:40 •  Информатика

Нужно написать программу на pascal.программа должна посчитать среднюю оценку ученика.например: "введите ваши оценки: 54454",программа должна вывести: "ваш средний : 4,4".человек может вводить сколько угодно значений

Ответ:
друг32
друг32
04.10.2020 11:26
Var marks:string; i,m,c,s,k:integer;
begin
write('Введите ваши оценки: ');
readln(marks);
s:=0; k:=0;
for i:=1 to length(marks) do
 if marks[i] in ['2'..'5']
  then begin val(marks[i],m,c); s:=s+m; k:=k+1 end;
writeln('Ваш средний : ',s/k);
end.

Пример:
Введите ваши оценки: 54454
Ваш средний : 4.4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?