Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
maratkhan0311
28.08.2021 12:24 •
Информатика
Дан целочисленный массив а(m,n) задается с экрана либо генерируется в пределах -100 до 100. найти числа b1 b2 …bn равные суммам элементов строк. pascal abc.net
Ответ:
oksanademyanov
31.08.2020 13:53
import java.lang.*;
import java.util.*;
import java.math.*;
class {
public static void main(String[] args){
int m, n;
Scanner sc = new Scanner(System.in);
System.out.print("Enter m: "); m = sc.nextInt();
System.out.print("Enter n: "); n = sc.nextInt();
int A[][] = new int[m][n];
for(int i = 0; i < m; i++){
for(int j = 0; j < n; j++){
float random = (float) Math.random();
random *= -100;
int rand = (int) Math.ceil(random) + 200;;
if((i + j) == rand){
System.out.println("A: " + i + " " + j);
};
};
};
};
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Matthew0500
02.08.2021 11:16
информация передается со скоростью 6,75 мегабайт в секунду. Сколько объёма информации будет передан за 15 минут?...
monkey06
06.05.2020 16:22
PYTHON Знайти кількість чисел в масиві з 20 елементів, заповненому випадковим чином, які діляться на 3, але не діляться на 7....
ekaterinakostin
03.09.2020 01:35
Зробити в пайтон : вівчарка вкрала в магазині x сосисок ,а собака такса y. Хто вкрав більше і на скільки?...
kukusiki12345
06.06.2022 10:41
нужна по информатике, задание надо зделать как можно быстрее скинте ответ в файле Екселя и ворда...
БадАнгелина
04.02.2021 21:47
Небольшое сообщение на тему «Алгоритмы вокруг нас...
vikt24oria
06.08.2022 22:37
Контрольна робота з іноформатики 8 клас...
дима2872
26.01.2022 21:05
Место где объединяются веб-страницы называется...
suri4
19.05.2023 17:21
Python кр 8 клас інформатика...
goodwar40
04.11.2022 03:02
Антивирусная программа Преимущества Недостатки...
алина3734
17.12.2021 15:26
Напишите программу на C++ не сложную с объяснением....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
import java.util.*;
import java.math.*;
class {
public static void main(String[] args){
int m, n;
Scanner sc = new Scanner(System.in);
System.out.print("Enter m: "); m = sc.nextInt();
System.out.print("Enter n: "); n = sc.nextInt();
int A[][] = new int[m][n];
for(int i = 0; i < m; i++){
for(int j = 0; j < n; j++){
float random = (float) Math.random();
random *= -100;
int rand = (int) Math.ceil(random) + 200;;
if((i + j) == rand){
System.out.println("A: " + i + " " + j);
};
};
};
};
}