В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
hamidullinelnar
hamidullinelnar
18.09.2022 07:14 •  Информатика

Найти средние арифметические положительных и отрицательных элементов массива паскаль написать программу

Ответ:
настена26258
настена26258
08.09.2020 12:28
const
    handsfree = false;

var
    a: array[1..100] of real;
    i, n: integer;
    sum_pos, sum_neg: real;
    k_pos, k_neg: integer;

begin
    {ввод массива}
    if handsfree then
        n := random(20) + 5
    else begin
        write('n = ');
        readln(n);
    end;
    
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(100) - 50;
            write(a[i], ' ');
        end
        else readln(a[i]);
    end;
    writeln();
    
    {подсчет}
    sum_pos := 0;
    k_pos := 0;
    sum_neg := 0;
    k_neg := 0;
    for i := 1 to n do
    begin
        if a[i] > 0 then
        begin
            sum_pos := sum_pos + a[i];
            k_pos := k_pos + 1;
        end;
        
        if a[i] < 0 then
        begin
            sum_neg := sum_neg + a[i];
            k_neg := k_neg + 1;
        end;
    end;
    writeln('average (positives) = ', sum_pos / k_pos);
    writeln('average (negatives) = ', sum_neg / k_neg);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?