В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
13022010
13022010
06.06.2020 00:50 •  Информатика

Составьте программу сортировки по возрастанию значений трёх переменных: a,d,c.

Ответ:
orynbasar2001
orynbasar2001
04.10.2020 10:21
Var
    a, d, c, t: integer;

begin
    readln(a, d, c);
    if a < d then begin t := a;a := d;d := t; end;
    if a < c then begin t := a;a := c;c := t; end;
    if d < c then begin t := d;d := c;c := t; end;
    writeln(a, ' ', d, ' ', c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?