В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sofialesiuk
sofialesiuk
23.10.2021 12:28 •  Информатика

А)составить программу, которая увеличивает в 10 раз все элементы массива. б) заменяет все отрицательные элементы их индексами. сделать нужно и а и б. через паскаль надо.

Ответ:
Аоаоаоа13362727182
Аоаоаоа13362727182
04.10.2020 09:51
//PascalABC.NET 3.2 сборка 1318

//а

begin
  writeln('Введите размерность:');
  var n:=ReadInteger();
  writeln('Введите массив:');
  var ar:=ReadArrInteger(n);
  ar.Transform(x -> x*10);
  ar.Print;
end.

//б

begin
  writeln('Введите размерность');
  var n:=ReadInteger();
  writeln('Введите массив:');
  var ar:=ReadArrInteger(n);
  for var i:=0 to n-1 do            //индексация с 0
    if ar[i]<0 then ar[i]:=i;
  ar.Print;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?