В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
стас483
стас483
01.12.2020 09:22 •  Информатика

Дано натуральное число n (1< =n< =100000). требуется написать программу, определяющую для n, какая цифра больше – первая или последняя. формат входных данных: в единственной строке задано число n. формат выходных данных: в единственной строке необходимо вывести один символ: =, если цифры одинаковые, < , если первая цифра меньше последней, > , если первая цифра больше последней.

Ответ:
Математик094
Математик094
04.10.2020 09:31
Var n,k:integer;
begin
readln(n);
k:=n mod 10;
n:=n div 10;
while n>10 do n:=n div 10;
if k=n
 then writeln('=')
 else if n<k then writeln('<') else writeln('>');
end.

Пример:
652843
>
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?