Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
hamkochan
14.11.2020 19:44 •
Информатика
Информатика- паскальабс. 10 класс. массивы. заполнить массив размерностью 7x7 по правилу *. 000000 000000 000000 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
Ответ:
nestieeeeeee
04.10.2020 09:21
Const n=6;
var a:array[1..n,1..n] of integer;
i,j:integer;
begin
for i:=1 to n div 2 do
for j:=1 to n do a[i,j]:=0;
for i:=n div 2+1 to 6 do
for j:=1 to n do a[i,j]:=1;
for i:=1 to n do
begin
for j:=1 to n do write(a[i,j]:2);
writeln;
end;
end.
Результат:
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
1 1 1 1 1 1
1 1 1 1 1 1
1 1 1 1 1 1
0,0
(0 оценок)
Популярные вопросы: Информатика
WaterdropE
16.08.2020 21:39
1) Даны три числа. Возвести в квадрат те из них, значение которых отрицательны и найти их сумму....
StradasfeR
22.04.2021 22:12
Вычислить значения выражений: а) 20 div 6 b) 20 mod 6 c) 20 mod 4 d) 2 div 5 e) 123 div 0 g) 3.0 mod 3...
RassvetZaGorami
22.04.2021 22:12
Как записывается полная форма записи оператора выбора на языке paskal?...
HermioneGranger19
22.04.2021 22:12
Создайте страницу vasilek.html ширина таблицы 900 px, ширина правой колонки 300 px аналогично сделайте страницы romashka.hyml и oduvanchik.html доп.информ. василёк — род...
scorp2003
06.01.2023 06:06
Який з операторів обчислює суму n перших парних чисел...
11041980
04.08.2021 22:56
1. Составить программу, которая генерирует 10-значный код из букв, цифр и знаков пунктуации. 2. *Используя строковую функцию isnumber(), которая проверяет, есть ли в строке...
svsand
08.04.2021 05:22
Rewrite the sentences in the Passive voice. The students are using the devices right now.The staff could have kicked her out of the restaurant.You should review the lessons...
vadim2810
08.04.2021 05:22
What is favorite fruit of the boy?...
romatkachuk19
08.04.2021 05:22
Додайте фото завдань 5-6 клас 2021 соняшник. Будь ласка...
linakkj
08.04.2021 05:22
Перевірте чи є число два -3x+4=12-x...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a:array[1..n,1..n] of integer;
i,j:integer;
begin
for i:=1 to n div 2 do
for j:=1 to n do a[i,j]:=0;
for i:=n div 2+1 to 6 do
for j:=1 to n do a[i,j]:=1;
for i:=1 to n do
begin
for j:=1 to n do write(a[i,j]:2);
writeln;
end;
end.
Результат:
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
1 1 1 1 1 1
1 1 1 1 1 1
1 1 1 1 1 1