В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Мирэя
Мирэя
29.03.2021 04:35 •  Информатика

Информатика 9 класс 50 написать программу в abcпаскаль которая вычислит сумму цифр пятизначного числа и определит находится ли эта сумма в диапазоне от 20 до 25 включительно(< = или > =)

Ответ:
NeMaximilan
NeMaximilan
02.08.2020 12:56
Var
  i, c: int64;
  s: string;
 begin
  readln(s);
  if(s.Length = 5) then
begin
    for i := 1 to 5 do
      c := c + strtoint(s[i]);
    writeln(c);
    if(c >= 20) and (c <= 25) then write('Находится')
    else write('Не находится');
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?