В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Sem0001
Sem0001
29.07.2020 05:27 •  Информатика

Y=x*cos(x)+sin(x) написать программу цикл с параметром и с предусловием pascal abc

Ответ:
катя120981
катя120981
04.10.2020 08:54
1)
const x0=1.0; xk=2.0; h=0.1;
var x,y:real; i:integer;
begin
x:=x0-h;
for i:=1 to round((xk-x0)/h)+1 do
 begin
 x:=x+h;
 y:=x*cos(x)+sin(x);
 writeln(x:3:1,y:7:3);
 end;
end.

2)
const x0=1.0; xk=2.0; h=0.1;
var x,y:real;
begin
x:=x0-h;
while x<xk do
 begin
 x:=x+h;
 y:=x*cos(x)+sin(x);
 writeln(x:3:1,y:7:3);
 end;
end.

Результат:
1.0  1.382
1.1  1.390
1.2  1.367
1.3  1.311
1.4  1.223
1.5  1.104
1.6  0.953
1.7  0.773
1.8  0.565
1.9  0.332
2.0  0.077
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?