В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Браснуев21
Браснуев21
25.02.2021 10:51 •  Информатика

Напишите программу для нахождения наибольшего общего делителя двух чисел с использованием процедуры. найти наибольший общий делитель для чисел 12, 24, 30, 48 и 51

Ответ:
llboyn
llboyn
04.10.2020 08:42
var a,b: integer;
function NOD(x,y: integer): integer;
begin;
   if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y;
end;
begin;
   readln(a,b);
   writeln( 'НОД = ', NOD(a,b) );
end.
Такой вопрос уже был... на этом сайте
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?