В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Yurianvinokurov
Yurianvinokurov
15.06.2022 19:44 •  Информатика

Синформатикой напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [100; 200] и находит в нём пару соседних элементов, сумма которых минимальна.

Ответ:
missana12345
missana12345
31.08.2020 12:51
C++:
for(int i = 0; i< 20; i++){
a[i]=rand()%101+100;
}
int pos=0;
for(int i = 0; i< 20; i++){
if(a[i]+a[i+1]<a[pos]+a[pos+1]){
pos=i;
}
0,0(0 оценок)
Ответ:
пллсыео
пллсыео
31.08.2020 12:51
Var a:array[1..20] of integer;
i,min,ind:integer;
begin 
randomize;
for i:=1 to 20 do begin
a[i]:=random(100)+100;
write(a[i]:4);
end;
writeln;
min:=a[1]+a[2];
for i:=2 to 19 do
if a[i]+a[i+1]<min then 
begin 
min:=a[i]+a[i+1];
ind:=i;
end;
write('Сумма минимальна между ',ind,' и ', ind+1, ' элементом');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?