В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Катер007
Катер007
27.02.2022 06:14 •  Информатика

Составьте программу нахождения количества делителей числа n (значение n вводится с клавиатуры)

Ответ:
1zoya
1zoya
20.08.2020 06:21
uses crt;
Var x, y, k:integer;
procedure delit;
begin  k:=0;  
writeln('Делители числа ', x, ':');  
for y:=1 to x do  if x mod y=0 then
begin
write( y, ' ');  
k:=k+1
end;  
writeln('Количество делителей числа ', x, ' равно ', k);
end;
begin clrscr;  
writeln ('Введите число: ');  
readln (x);  
delit;  
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?