В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу на pascal из трехзначного числа x вычли его последнюю цифру. когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x. то получилось число n. по заданному n найти число x (значение n вводится с клавиатуры, 10< =n< =999 , и при этом число десятков в n не равно нулю).

Ответ:
ніка2007
ніка2007
04.10.2020 06:29
Если было число ABC = X, то после деления на 10 стало AB, а после приписывания слева CAB = N. Для получения из N числа X просто переставляем первую цифру в конец.

var
  N: integer;

begin
  readln(N);
  write(10 * (N mod 100) + (N div 100))
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?