В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
LilianaLiLi1
LilianaLiLi1
26.02.2020 23:25 •  Информатика

Напишите программу: мальчик саша учится в школе ш, одна из особенностей которой состоит в том что на уроках в ней ставят только двойки и пятёрки. саша заранее узнал, на каких уроках языка он получит 2, а на каких — 5. саша идёт на деревянную медаль, и поэтому ему надо получить оценку за год не ниже 4 (четвёрка ставится, если хотя бы половина оценок — пятёрки, и при этом есть хотя бы одна оценка). он хочет прогулять часть уроков, чтобы исправить ситуацию (если саша прогуливает урок, он не получает никакой оценки). но саша — добропорядочный мальчик, поэтому он хочет прогулять минимальное количество уроков. ему.

Ответ:
Romays
Romays
04.10.2020 04:41
//Dev-C++ 5.11 (C)

#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>

int main(void)
 {int n,mark,count2=0,count5=0,res;
 printf("Enter number of classes:");
 scanf("%d",&n);
 printf("Enter marks:\n");
 for(int i=0;i<n;i++)
 {scanf("%d",&mark);
 if(mark==5) count5++;
    if(mark==2)
     count2++;}
    res=count2-count5;
    if (res<0)
  res=0;
    if (count5==0)
  printf("Impossible");
 else
  printf("%d",res);
 return 0;}

Пример ввода:
3
5
2
2
Пример вывода:
1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?