В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
iriska198501
iriska198501
17.10.2021 20:18 •  Информатика

Напишите программу, которая считывает с клавиатуры n чисел и затем выводит на экран сумму и среднее арифметическое отрицательных чисел. в паскаль

Ответ:
artyommakarov1
artyommakarov1
04.10.2020 04:33
Var i,n,nmb: integer;
    dg,sm: real;
begin
  sm:=0;  nmb:=0;
  write('n = ');
  readln(n);
  write('числа через пробел: ');
  for i:=1 to n do
  begin
    read(dg);
    if dg<0 then
    begin
      sm:=sm+dg;
      nmb:=nmb+1;
    end;  
  end;
  writeln('сумма отрицательных чисел = ',sm);
  writeln('среднее арифметическое = ',sm/nmb);
end.    
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?