В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Дано n последовательных натуральных чисел начиная с 1.написать программу,вычисляющую их среднее арифметическое

Ответ:
79268888397p06sqw
79268888397p06sqw
20.08.2020 01:29
Import java.util.Scanner;
import java.io.*;
public class Sred {
public static void main(String[] args) {
 Scanner in = new Scanner(System.in);
 int n;
 System.out.print("n=");
 n = in.nextInt();
 int[] a = new int[n];
int sum = 0;
 for (int i = 0; i < n; i++) {
  a[i] = in.nextInt();
  sum += a[i];
 }
 float sred = (float)sum / n;
 System.out.printf("Среднее арифметическое: %.1f \n", sred);
 }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?