В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Аня276541
Аня276541
13.11.2020 18:26 •  Информатика

Напишите программу для того чтобы протестировать детей как они умеют считать? показывается пример они считают в паскале!

Ответ:
Неко6тян
Неко6тян
02.08.2020 10:22
Var
   n, i, r, sum, s: integer;
  ms: array[1..100]of char;
begin
  randomize;
  n := random(3, 7);
  var ar := arrrandom(n, 1, 50);
  for i := 1 to n - 1 do
   begin
    r := random(1, 2);
     if(r = 1) then ms[i] := '+'
     else ms[i] := '-' end;
  s := ar[0];
  write(ar[0], ' ');
  for i := 1 to n - 1 do
   begin
    write(ms[i], ' ', ar[i], ' ');
    if(ms[i] = '+') then s := s + ar[i]
    else s := s - ar[i];
  end;
  write(' = ');
  read(sum);
  if(s = sum)
then
write('Правильно')
   else
write('Неправильно, правильный ответ : ', s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?