В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
TanyaMakarova26
TanyaMakarova26
22.08.2022 13:32 •  Информатика

Написать программу на языке с++: из данной строки удалить все цифры и малые латинские буквы

Ответ:
diaabd150ozrpt6
diaabd150ozrpt6
04.10.2020 03:41
//Dev-C++ 5.11

#include <iostream>
#include <string>
using namespace std;

int main(void)
 {string s;
 int i=0,k=0;
 cin>>s;
 k=s.length();
 while (k!=i)
  {if((s[i]>='0'&&s[i]<='9')||(s[i]>='a'&&s[i]<='z'))
   s.erase(s.begin()+i);
  else
   i++;
  k=s.length();}
 cout<<endl<<s;
 return 0;}

Пример ввода:
WaTerMeL1oN
Пример вывода:
WTMLN
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?