В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dasha8743
dasha8743
14.04.2023 01:27 •  Информатика

Написать программу на паскале 1.написать функцию,подсчитывающую количество единиц в числе и с её определить,в каком из двух чисел единиц больше.

Ответ:
Босс05
Босс05
04.10.2020 03:38
Var
  s, s2: string;

 function one(s: string): integer;
var i, c: integer;
begin
  c := 0;
  for i := 1 to length(s) do
    if (s[i] = '1') then c := c + 1;
  result := c;
end;

 begin
  writeln('Введите первое число:');
  readln(s);
  writeln('Введите второе число:');
  readln(s2);
  if(one(s) > one(s2)) then write('В первом числе больше единиц')
  else write('Во втором числе больше единиц');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?