В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ketrin0309
ketrin0309
11.04.2021 06:34 •  Информатика

350 ! пр информатике. на pascal abc. надо написать программу где нужно ввести 5 цифр в столбик. дальше вывести их на экран. и в конце нужно самое большое число и самое маленькое и поменять их местами.
например:
я ввожу
6
7
8
9
10
максимум-10
минимум-6
10
7
8
9
6
напишите с объяснением

Ответ:
TayniDzho
TayniDzho
07.08.2019 20:10

var max,min,a: integer;

mas: array[1..5] of integer;

begin

for a: =1 to 5 do

begin

readln(mas[a]);

if mas[a]< =mas[min] then min: =a ;

if mas[a]> =mas[max] then max: =a ;

end;

writeln;

writeln (mas[max]);

for a: =1 to 5 do

if (a< > min)and(a< > max) then writeln (mas[a]);

writeln(mas[min]);

end.

0,0(0 оценок)
Ответ:
Ali0429
Ali0429
07.08.2019 20:10

ответ:

var max,min,a: integer;

mas: array[1..5] of integer;

begin

for a: =1 to 5 do

begin

readln(mas[a]);

if mas[a]< =mas[min] then min: =a ;

if mas[a]> =mas[max] then max: =a ;

end;

writeln;

writeln (mas[max]);

for a: =1 to 5 do

if (a< > min)and(a< > max) then writeln (mas[a]);

writeln(mas[min]);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?