В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
gyuzal1
gyuzal1
21.01.2023 23:09 •  Информатика

Ниже на пяти языках программирования записан алгоритм. получив на вход число x, этот алгоритм печатает число m. известно, что x > 150. укажите наименьшее такое (т. е. большее 150) число x, при вводе которого алгоритм печатает 30. var x, l, m: integer; begin readln(x); l : = 2*x-30; m : = 2*x+30; while l < > m do begin if l > m then l : = l - m else m : = m - l; end; writeln(m); end.

Ответ:
Кисулятв
Кисулятв
04.10.2020 03:29
# Код на ruby 2.2.3p173
def z(x)
    l = 2 * x + 30
    m = 2 * x - 30

    while m!=l do
        if l > m
            l = l - m
        else
            m = m - l;
        end
    end

    return m
end

for x in 151..2000
    if z(x) == 30
        p x
        break
    end
end

ответ 180
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?