В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Юлия45684
Юлия45684
17.04.2021 21:35 •  Информатика

Составить программу в pascal, которая вводит строку символов, удаляя все символы, не являющиеся латинскими буквами и затем выводит результаты.

Ответ:
GGNOOB777
GGNOOB777
04.10.2020 01:53
//PascalABC.NET 3.2 сборка 1318

var
  s: string;
  i,k: integer;

begin
  readln(s);
  i:=1;
  k:=length(s);
  while i<>k do
  begin
    k:=length(s);
    if (upcase(s[i]) < 'A') or (upcase(s[i]) > 'Z') then
      begin
        delete(s, i, 1);
        i:=i-1;
      end;
    i:=i+1;
  end;
  writeln(s);
end.

Пример ввода:
Gleb1Kosyrev Sample Текст, Pointer Symbol is ^
Пример вывода:
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?