В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Стивен12
Стивен12
16.01.2023 03:28 •  Информатика

/ивт 9 класс делфи / паскаль/ 50 напишите программу, которая по данному натуральному числу n выводит все его простые натуральные делители с учетом кратности. время работы программы должно быть пропорционально корню из n. входные данные программа получает на вход одно число n< 2^31. выходные данные программа должна вывести все простые натуральные делители числа n с учетом кратности в порядке неубывания. примеры входные данные 6 выходные данные 2 3

Ответ:
aryka2
aryka2
04.10.2020 00:52
Var
 n,d,k:int64;
begin
 read(n);
 d := 2; k := 4;
 while k <= n do
  begin
  while n mod d = 0 do
    begin
    write(d,' ');
    n := n div d;
    end;
  k := k + 2*d + 1;
  d := d + 1;
  end;
 if n > 1 then write(n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?