Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Кукарику12
30.06.2022 08:30 •
Информатика
Создать массив в ведением элементов с клавиатуры.количество элементов так же вводится с клавиатуры.написать процедуру ввода с клавиатуры,процедуру вывода в столбик,отсортировать методом пузырька и вывести полученный массив.
Ответ:
Angilass
02.08.2020 09:20
//Dev-C++ 5.11 (C)
#include <stdio.h>
#include <malloc.h>
void reading(int*,int);
void writing(int*,int);
int main(void)
{int *Array,n,c;
scanf("%d",&n);
Array=(int*)malloc(n*sizeof(int));
reading(Array,n);
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
if(Array[i]>Array[j])
{c=Array[i];
Array[i]=Array[j];
Array[j]=c;}
writing(Array,n);
return 0;}
void reading(int *Array,int n)
{for(int i=0;i<n;i++)
scanf("%d",&Array[i]);}
void writing(int *Array,int n)
{for(int i=0;i<n;i++)
printf("%d \n",Array[i]);}
Пример ввода:
3
1
3
2
Пример вывода:
3
2
1
0,0
(0 оценок)
Ответ:
плиз168
02.08.2020 09:20
//c#
using System; namespace ConsoleApplication1 { class Program { static void Main(){ Console.writeline("Write array lenght"); string[int32.Parse(Console.ReadLine())] ar; for(int i=0;i<ar.lenght;++i){ ar[i]=Console.ReadLine(); } Console.Clear(); for(int i=0;i<ar.lenght;++i){ Console.WriteLine(ar[i]); } Console.Read(); } }}
0,0
(0 оценок)
Популярные вопросы: Информатика
Vitruviius
17.01.2021 16:29
Проверить возможность построения треугольника из отрезков заданной длины, узнать вид треугольника(прямоугольный, остроугольный, тупоугольный)...
ТупенькийХлебушек1
08.04.2020 18:51
Для хранения одного пикселя требуется 12 байт. какое кол-во памяти в кбитах необходимо для хранения раствотрого изображения размером 640*480 пикселей....
323данилаАт
08.04.2020 18:51
Барс решил осмотреть достопримечательности города. в конце путешествия барс устал и сменил одежду. напишите программу, которая будет выполнять действия барса, используя...
тимур618
28.07.2021 03:34
Найдите все элементы матрицы (n,m) кратные 5 и сохраните их в одномерном массиве. надо...
angelinaoguzova
21.01.2023 17:36
Укажите причину по которой сейчас не используется дискета: а. необходимость специального устройства для чтения. б . малая емкость и ненадежность c . не удобства транспортировки...
Retrostyle
05.03.2023 03:32
Перевести текст но не с интернет переводчиком the sun and the planets,the moon and the satellites of the other planets,the comets,asteroids,and meteorites make up the...
ятупик2
05.03.2023 03:32
Какие несьедобные шляпочные грибы вы знаете? ?...
skskkslslw
05.03.2023 03:32
Как обозначить пословицы на тему труд...
Marymol2005
05.03.2023 03:32
Приняв во внимание свойства веществ, объясните, почему отвертки и плоскогубцы имеют, как правило, пластмассовые ручки?...
Rashidleo
05.03.2023 03:32
Вперееосном значений слова игрушки детские...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <stdio.h>
#include <malloc.h>
void reading(int*,int);
void writing(int*,int);
int main(void)
{int *Array,n,c;
scanf("%d",&n);
Array=(int*)malloc(n*sizeof(int));
reading(Array,n);
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
if(Array[i]>Array[j])
{c=Array[i];
Array[i]=Array[j];
Array[j]=c;}
writing(Array,n);
return 0;}
void reading(int *Array,int n)
{for(int i=0;i<n;i++)
scanf("%d",&Array[i]);}
void writing(int *Array,int n)
{for(int i=0;i<n;i++)
printf("%d \n",Array[i]);}
Пример ввода:
3
1
3
2
Пример вывода:
3
2
1
using System; namespace ConsoleApplication1 { class Program { static void Main(){ Console.writeline("Write array lenght"); string[int32.Parse(Console.ReadLine())] ar; for(int i=0;i<ar.lenght;++i){ ar[i]=Console.ReadLine(); } Console.Clear(); for(int i=0;i<ar.lenght;++i){ Console.WriteLine(ar[i]); } Console.Read(); } }}