В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sofi190
sofi190
23.03.2022 11:46 •  Информатика

Написать программу в си++. такая : если сумма трёх попарно различных действительных чисел x,y,z меньше единицы, то наименьшее из этих трёх чисел заменить полусуммой двух других; в противном случае заменить меньшее из x и y полусуммой двух оставшихся значений. заранее ))

Ответ:
Anton2657
Anton2657
04.10.2020 00:38
//Dev-C++ 5.11

#include <iostream>
using namespace std;

int main(void)
 {float x,y,z=0;
 cin>>x>>y>>z;
 if(x+y+z<1)
  {float min=x;
  if (min>y) min=y;
  if (min>z) min=z;
  if (min==x) x=(y+z)/2;
  if (min==y) y=(x+z)/2;
  if (min==z) z=(x+y)/2;}
  else
  if(x>y) y=(x+z)/2; else x=(y+z)/2;
 cout<<x<<" "<<y<<" "<<z<<" ";
 return 0;}

Пример ввода:
1.1
2.2
3.3
Пример вывода:
2.75 2.2 3.3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?