В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
123443123
123443123
05.01.2021 10:40 •  Информатика

Паскаль (с использованием операторов if и elsе) напишите программу, которая по введенным с клавиатуры числам e, f, g, h и w будет вычислять значение коэффициента a, b и c квадратного уравнения по предлагаемым формулам, а также значение дискриминанта d, решать это квадратное уравнение и выдавать результаты его решения. a=7e-f/2, b=√((g+e)^2+h/w), c=|w^2-h| sin⁡a, где дискриминант d=b^2-4ac; корни уравнения x_1,2=(-b±√d)/2a. отладьте программу на следующем примере: е=2, f= -5, g=-5, h=3, w=2 a=16.5 b=3.24037 c=-0.711785 d=57.4778 x1=0.131547 x2=-0.327933

Ответ:
Пусик95
Пусик95
03.10.2020 23:53
Var
   e,f,g,h,w,a,b,c,D:real;
begin
readln(e);
readln(f);
readln(g);
readln(h);
readln(w);
a:=7*e-f/2;
b:=sqrt(sqr(g+e)+h/w);
c:=abs(sqr(w)-h)*sin(a);
D:=sqr(b)-4*a*c;
writeln('a = ',a);
writeln('b = ',b);
writeln('c = ',c);
writeln('D = ',D);
if(D<0) then writeln('Корней нет')
else if(D = 0) then
  writeln('x = ',-b/(2*a))
else
begin
  writeln('x1 = ',(-b+sqrt(D))/(2*a));
  writeln('x2 = ',(-b-sqrt(D))/(2*a));
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?