В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sviridovaliza19
sviridovaliza19
01.06.2021 17:02 •  Информатика

Дано натуральное число n (1< =n< =10000). требуется написать программу, определяющую для n, какая цифра больше - первая или последняя тех. требования: входной файл: input.txt выходной файл: output.txt ограничение по времени 1 секунда формат входных данных: в единственной строке задано число n. формат выходных данных: в единственной стоке необходимо вывести один символ: "=", если цифры одинаковые"< ", если первая цифра меньше последней, и "> ", если первая цифра больше последней. пример файла входных данных: 1234 пример файла выходных данных:

Ответ:
neket678885
neket678885
03.10.2020 22:55
Var
  n,d:integer;
  f:Text;
begin
  Assign(f,'input.txt'); Reset(f);
  Read(f,n);
  Assign(f,'output.txt'); Rewrite(f);
  d:=n mod 10;
  while n>=10 do n:=n div 10;
  if n>d then Writeln(f,'>')
  else
    if n=d then Writeln(f,'=') else Writeln(f,'<');
  Close(f)
end.
0,0(0 оценок)
Ответ:
shapovalovalyubochka
shapovalovalyubochka
03.10.2020 22:55
Char * buffer = new char[1000];

ifstream filein("INPUT.TXT", ios::in);
filein.getline(buffer, 1000);
filein.close();

string str = string(buffer);
delete[] buffer;

ofstream fileout("OUTPUT.TXT", ios::out);
if (str[0] == str[str.length() - 1]) fileout << "=";
if (str[0] == str[str.length() - 1]) fileout << "<";
if (str[0] == str[str.length() - 1]) fileout << ">";
fileout.close();
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?